Faq view table of predictions scores or other data

From Eigenvector Documentation Wiki
Jump to: navigation, search

Issue:

How do I view a table of predictions, scores, or other data?

Possible Solutions:

By default, Analysis creates a plot of most predicted values including scores, predicted y-values, classes, etc (essentially any value calculated in or from a model). These plots are accessed through the Analysis Window toolbar buttons.

If you wish to view any of these items in a table instead of a plot, click the toolbar button which generates the information you want; This generates the plot. Then, use one of these two routes to viewing the table:

  1. click on the "View/Edit Data in Editor" toolbar button
  2. in Plot Controls, select the File → Edit Data menu item.

Either of these will open a DataSet editor showing you the raw data from which the currently viewed plot was created from (See the Data tab).

You can also export this data to the base workspace, save to a MAT file, or export to an another file format through the File menu on the DataSet Editor.

For example, you could select the "Y Measured..." and "Y Predicted ..." columns in the Dataset Editor and then use the menu:
"File"→"Extract Data"→"As Raw Data"
to save these columns to your workspace. Now double-clicking on this item will open it in a Dataset Editor and you save just these columns as a text file by using the menu:
"File"→"Export To"→"Comma Separated Values File (CSV)"
An alternative approach is to simply to select the columns you want in the Dataset Editor and copy them to the clipboard by Ctrl-C or menu:
"Edit"→"Copy"
and then paste these values into a text editor.

Note: This method works for any plot which is being controlled by the Plot Controls window. Not just plots from the Analysis window.


Still having problems? Please contact our helpdesk at helpdesk@eigenvector.com