Faq getting out of memory errors when using preprocessing in GUI

From Eigenvector Documentation Wiki
Jump to: navigation, search

Issue:

I am getting out of memory errors when using preprocessing in Analysis GUI - how do I analyze this data within the GUI?

Possible Solutions:

Some data will be too large for PLS_Toolbox or Solo to analyze. However, there are some tricks which will make it more feasible. First, see the FAQ item I keep getting "out of memory" errors when analyzing my data. What can I do?.

Next, one common problem happens when using preprocessing in Analysis GUI. Preprocessing requires that Analysis GUI make an copy of your entire data set (it always saves the original data since some preprocessing methods are non-reversible). The steps below outline a method to preprocess your data beforehand, and free up the memory used to store the original data (these steps assume you are using Version 5.x of Solo or PLS_Toolbox).


  1. Load your original raw data into Analysis as the X-block
  2. Choose preprocessing: Click on the (P) next to the X-block and choose which method(s) you want to use (or use the Preprocessing menu, choosing X-block and the appropriate sub-item)
  3. Save the preprocessed data: In the File menu, choose Save Data → Calibration → Save Preprocessed X-block Data.
  4. Choose to save the data to the workspace with some name (you could also save to the disk - just know you must load back from the disk in step (7) below)
  5. Clear data from Analysis: In the File menu, choose Clear → All
  6. Clear your original data from the workspace (NOTE: If you loaded the data directly into Analysis from a file, there will be no copy of the data in the workspace and you can skip this step) :
    PLS_Toolbox Users: At the matlab command line, clear the variable which holds your original raw (non-preprocessed) data: clear YourVariableName
    Solo Users: Select "Workspace Browser" from the Fig Browser menu. In the workspace browser, select the variable which holds your original raw (non-preprocessed) data and press the "delete" key.
    This will free the memory which holds your original data.
  7. Load the preprocessed data: in the Analysis GUI, load the PREPROCESSED data into X
  8. Set the preprocessing to be NONE (see step (2) ) - clear all items from the list.
  9. Apply analysis method of choice to the data


Still having problems? Please contact our helpdesk at helpdesk@eigenvector.com